Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-cli - Command-line interface for PHP

Website:
http://www.php.net/
Licence:
PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and PostgreSQL
Vendor:
Remi's RPM repository <https://rpms.remirepo.net/> #StandWithUkraine
Description:
The php-cli package contains the command-line interface
executing PHP scripts, /usr/bin/php, and the CGI interface.

Packages

php-cli-8.1.9-1.el8.remi.x86_64 [5.3 MiB] Changelog by Remi Collet (2022-08-02):
- Update to 8.1.9 - http://www.php.net/releases/8_1_9.php
php-cli-8.1.8-1.el8.remi.x86_64 [5.3 MiB] Changelog by Remi Collet (2022-07-06):
- Update to 8.1.8 - http://www.php.net/releases/8_1_8.php
php-cli-8.0.22-1.el8.remi.x86_64 [4.7 MiB] Changelog by Remi Collet (2022-08-02):
- Update to 8.0.22 - http://www.php.net/releases/8_0_22.php
php-cli-8.0.21-2.el8.remi.x86_64 [4.7 MiB] Changelog by Remi Collet (2022-07-06):
- Update to 8.0.21 - http://www.php.net/releases/8_0_21.php
- rebuild with new sources
php-cli-7.4.30-1.el8.remi.x86_64 [4.6 MiB] Changelog by Remi Collet (2022-06-07):
- Update to 7.4.30 - http://www.php.net/releases/7_4_30.php
- use oracle client library version 21.6
php-cli-7.4.29-1.el8.remi.x86_64 [4.6 MiB] Changelog by Remi Collet (2022-04-12):
- Update to 7.4.29 - http://www.php.net/releases/7_4_29.php
php-cli-7.3.33-3.el8.remi.x86_64 [4.6 MiB] Changelog by Remi Collet (2022-06-07):
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
- pgsql: fix #81720: Uninitialized array in pg_query_params(). CVE-2022-31625
- pcre: fix default options for pcre >= 10.38
php-cli-7.3.33-1.el8.remi.x86_64 [4.6 MiB] Changelog by Remi Collet (2021-11-16):
- Update to 7.3.33 - http://www.php.net/releases/7_3_33.php
php-cli-7.2.34-11.el8.remi.x86_64 [4.7 MiB] Changelog by Remi Collet (2022-06-07):
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
- pgsql: fix #81720: Uninitialized array in pg_query_params(). CVE-2022-31625
php-cli-7.2.34-10.el8.remi.x86_64 [4.7 MiB] Changelog by Remi Collet (2021-11-15):
- Fix #79971 special character is breaking the path in xml function
  CVE-2021-21707