Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-interbase - A module for PHP applications that use Interbase/Firebird databases

Website:
http://www.php.net/
Licence:
PHP
Vendor:
Remi's RPM repository <https://rpms.remirepo.net/> #StandWithUkraine
Description:
The php-interbase package contains a dynamic shared object that will add
database support through Interbase/Firebird to PHP.

InterBase is the name of the closed-source variant of this RDBMS that was
developed by Borland/Inprise.

Firebird is a commercially independent project of C and C++ programmers,
technical advisors and supporters developing and enhancing a multi-platform
relational database management system based on the source code released by
Inprise Corp (now known as Borland Software Corp) under the InterBase Public
License.

Packages

php-interbase-7.3.33-6.el8.remi.x86_64 [120 KiB] Changelog by Remi Collet (2022-10-24):
- hash: fix #81738: buffer overflow in hash_update() on long parameter.
  CVE-2022-37454
php-interbase-7.3.33-5.el8.remi.x86_64 [120 KiB] Changelog by Remi Collet (2022-09-27):
- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
- core: fix #81727 Don't mangle HTTP variable names that clash with ones
  that have a specific semantic meaning. CVE-2022-31629
- use oracle client library version 21.7
php-interbase-7.2.34-14.el8.remi.x86_64 [117 KiB] Changelog by Remi Collet (2022-10-24):
- hash: fix #81738: buffer overflow in hash_update() on long parameter.
  CVE-2022-37454
php-interbase-7.2.34-13.el8.remi.x86_64 [117 KiB] Changelog by Remi Collet (2022-09-27):
- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
- core: fix #81727 Don't mangle HTTP variable names that clash with ones
  that have a specific semantic meaning. CVE-2022-31629
- use oracle client library version 21.7