Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-oci8 - A module for PHP applications that use OCI8 databases

Website:
http://www.php.net/
Licence:
PHP
Vendor:
Remi's RPM repository <https://rpms.remirepo.net/> #StandWithUkraine
Description:
The php-oci8 packages provides the OCI8 extension version 2.2.0
and the PDO driver to access Oracle Database.

The extension is linked with Oracle client libraries 21.7
(Oracle Instant Client).  For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).

You must install libclntsh.so.21.1 to use this package, provided
in the database installation, or in the free Oracle Instant Client
available from Oracle.

Notice:
- php-oci8 provides oci8 and pdo_oci extensions from php sources.
- php-pecl-oci8 only provides oci8 extension.

Documentation is at http://php.net/oci8 and http://php.net/pdo_oci

Packages

php-oci8-7.3.33-5.el8.remi.x86_64 [170 KiB] Changelog by Remi Collet (2022-09-27):
- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
- core: fix #81727 Don't mangle HTTP variable names that clash with ones
  that have a specific semantic meaning. CVE-2022-31629
- use oracle client library version 21.7
php-oci8-7.3.33-3.el8.remi.x86_64 [170 KiB] Changelog by Remi Collet (2022-06-07):
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626
- pgsql: fix #81720: Uninitialized array in pg_query_params(). CVE-2022-31625
- pcre: fix default options for pcre >= 10.38